ORC Radio Chatter

General Category => Questions => Topic started by: ac9cd on July 03, 2013, 06:30:17 PM

Title: Radio - amplifier interface
Post by: ac9cd on July 03, 2013, 06:30:17 PM
Can anyone provide me some assistance with interfacing my Yaesu FT-950 with an Ameritron ALS-600 amp? I'm having a hard time setting the ALC and preventing the load fault circuit from activating. If you can help, call or send me an email, and I'll fill you in on all the details. Thanks. Art Davidson AC9CD
Title: Re: Radio - amplifier interface
Post by: K9DJT on July 08, 2013, 08:12:53 AM
Hi Art,

I have no direct experience with your amplifier, but did a refurbish and modification of an old 1960's amp which I drive with an FT-2000. 

What I learned was that I was over driving the amp, i.e, using a 100 watts because that was what the amp manual said I could do.  The key word is "could".  I now drive it with only 50 watts and obtain full output power of the amp.  Not sure if this will help or not, but it would be worth a try.

You might want to try contacting Chuck, W9POU, who has a lot of experience home-brewing amps.

Look forward to seeing you at the meeting.

73, Gary
K9DJT
Title: Re: Radio - amplifier interface
Post by: ac9cd on July 08, 2013, 09:15:54 AM
Hi Gary,

Thanks for the info. I did decrease the drive to 90 watts, and everything was fine on 20 and 40 meters last night. I didn't try it on 15 yet; that's where I was having a problem last week (no SWR issues). I'll try 15 today and see what happens, but the decreased drive seemed to help.

Thanks again for your advice. See you Wednesday.

Art